Our monitoring has not shown any signs of lingering issues in the hour following our cloud providers marking of their incident as closed. We are considering this incident resolved.
Posted Oct 20, 2025 - 17:18 PDT
Monitoring
Our monitoring has been showing stable for the last hour despite our cloud provider maintaining degraded service status. We are expecting Omni services to be performing as expected.
We will continue to monitor until our cloud provider reports all systems are stable.
Posted Oct 20, 2025 - 14:11 PDT
Update
We have been able to add some new resources to our infrastructure. Monitoring shows some improvement may be experienced in query processing.
We are continuing to monitor and attempt to return to a fully stable service as soon as is allowed by our cloud provider's state of service.
Posted Oct 20, 2025 - 12:47 PDT
Update
No change from last status update. We continue to monitor closely and will scale up resources as soon as our cloud provider allows.
Query execution is still backlogged until our cloud service provider's infrastructure allows us to provision more capacity, queries are executed in the order they are received, rerunning a query will not result in faster execution.
Posted Oct 20, 2025 - 10:17 PDT
Update
Query execution is backlogged until our cloud service provider's infrastructure allows us to provision more capacity, queries are executed in the order they are received, rerunning a query will not result in faster execution.
Posted Oct 20, 2025 - 07:23 PDT
Identified
We are experiencing delays executing queries in Omni's US environment due to infrastructure issues with our cloud service provider.