Slowness detected in Omni

Incident Report for Omni Analytics

Resolved

The incident has been resolved, and all systems are back to operational status. We apologize for the disruption and are conducting a review to prevent the issue from happening again.
Posted Feb 25, 2026 - 11:22 PST

Monitoring

The application is back online, and our monitoring shows performance metrics have returned to normal levels. We are continuing to monitor the situation.
Posted Feb 25, 2026 - 11:10 PST

Update

We are continuing to work on a fix for this issue.
Posted Feb 25, 2026 - 11:02 PST

Identified

The team identified a recent change that caused performance degradation. We have rolled back to a previous deployment and are seeing recovery.
Posted Feb 25, 2026 - 10:58 PST

Update

We have identified the cause of the issue and are in the process of reverting the change.
Posted Feb 25, 2026 - 10:48 PST

Investigating

Our monitoring picked up slowness in the Omni App with error messages in some cases. We are investigating and working on mitigation.
Posted Feb 25, 2026 - 10:44 PST
This incident affected: EastUsa and Ireland.