Slowed Query Executions

Incident Report for Omni Analytics

Resolved

A fix has been implemented, and we’re monitoring to ensure the issue is resolved.
Posted Apr 14, 2025 - 17:35 PDT

Identified

We've identified the cause and we are working on a fix. You may continue to see slower-than-normal performance as we address the cause.
Posted Apr 14, 2025 - 17:00 PDT

Investigating

Omni is experiencing slowed query execution. We are actively addressing the issue.
Posted Apr 14, 2025 - 15:13 PDT
This incident affected: EastUsa.