Investigating slowness in Omni

Incident Report for Omni Analytics

Resolved

This incident is now resolved.
Posted Sep 10, 2025 - 10:46 PDT

Monitoring

Systems are showing stable and users are reporting normal behavior but we are continuing to monitor.
Posted Sep 10, 2025 - 09:48 PDT

Identified

The issue has been identified and a mitigation is being applied. We are seeing performance stabilize.
Posted Sep 10, 2025 - 09:44 PDT

Update

We are continuing to investigate this issue.
Posted Sep 10, 2025 - 09:40 PDT

Investigating

Our monitoring is showing slowness related to navigation and other actions within Omni. We are investigating the cause and possible mitigations.
Posted Sep 10, 2025 - 09:38 PDT
This incident affected: EastUsa and Ireland.