Slow UI navigation

Incident Report for Omni Analytics

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 13:46 PDT

Monitoring

We've deployed additional infra to handle the increased load that was causing performance degradation. While performance should be mostly recovered, we are investigating the root cause of the performance spike.
Posted Aug 17, 2026 - 10:42 PDT

Investigating

We have received reports of slowness navigating in Omni, we are currently investigating
Posted Aug 17, 2026 - 10:31 PDT
This incident affected: EastUsa.