Slack outage impacting support responses and Slack deliveries

Incident Report for Omni Analytics

Resolved

Slack has resolved this outage: https://slack-status.com/2025-02/1b757d1d0f444c34
Posted Feb 26, 2025 - 17:47 PST

Update

We are continuing to monitor for any further issues.
Posted Feb 26, 2025 - 09:20 PST

Update

Some scheduled deliveries to Slack channels and users are impacted by this outage.
Posted Feb 26, 2025 - 09:10 PST

Monitoring

Slack is having an outage that is impacting our ability to send and receive some support requests. For time-sensitive support issues use support@omni.co until Slack becomes fully operational.
Posted Feb 26, 2025 - 08:59 PST
This incident affected: EastUsa, Ireland, Australia, and Canada.