Slowness in Omni detected

Incident Report for Omni Analytics

Resolved

This incident is now resolved. In certain configurations combined with a very large number of model extensions it was possible to issue a query to the internal database that exhausted resources. Our mitigation is stable and a permanent fix is in development.
Posted Dec 04, 2025 - 09:12 PST

Update

We are continuing to monitor for any further issues.
Posted Dec 04, 2025 - 05:47 PST

Update

We have mitigated the issues for now and the app has stabilised with some continued slowness still expected.
We are continuing to look into the root cause to identify a permanent fix.
Posted Dec 04, 2025 - 03:51 PST

Update

We are still monitoring the results of the fix. Requests to our internal CPU continue to be high and we are working on bringing it down
Posted Dec 04, 2025 - 02:29 PST

Monitoring

A fix has been implemented and we're monitoring the results
Posted Dec 04, 2025 - 01:40 PST

Update

We are continuing to investigate the root cause of the issue
Posted Dec 04, 2025 - 01:34 PST

Investigating

We are aware of an internal error affecting access to Omni and are currently investigating
Posted Dec 04, 2025 - 01:15 PST
This incident affected: Ireland.